Apache Tomcat Monitoring

About Apache Tomcat Monitoring

Monitis Tomcat monitor provides a simple solution for users who want to monitor Java web applications. Currently Monitis Tomcat monitor supports Tomcat 5.5 and higher (though you can use it with Tomcat 5.0 as well but it’s not full proof).

Prerequisites

The following are the necessary pre-requisites for Tomcat monitor:

  • Java (JDK or JRE 1.5 or higher)Note: please take into account that Tomcat can only work with Java machine which is the same version as Tomcat or one version lower (for example, Tomcat6 can’t work with Java7). This information is available on Apache Tomcat web page .
  • Tomcat 5.5 or higher.
  • PowerShell 2.0 or higher (if Tomcat is installed on Windows machine). You should have it installed on the same machine where your Smart Agent is running.

Java, Tomcat and PowerShell installation is outside the scope of this document, so please refer to the product documentation of these tools for guidance.

  • Smart Agent (it’s not mandatory to have Smart Agent and Tomcat installed on the same machine: the Agent can connect to Tomcat running on a different machine).
Note:  as Tomcat monitor uses JMX Proxy Servlet it’s not necessary to have Java installed on the same server where Smart Agent is running.